View unanswered posts | View active topics It is currently Mon Dec 18, 2017 12:03 pm



Post new topic Reply to topic  [ 15 posts ] 
 3 annoying bugs 
Author Message
Soldier level 0
Soldier level 0

Joined: Mon Sep 28, 2015 4:13 am
Posts: 8
 3 annoying bugs
Well, I do realize this game is old, but I have these 3 really annoying bugs that is preventing me from enjoying the game.

The first bug is that sometime the cooling mode will get stuck on and will continuously cool down the ship and there doesn't seem to be a way to stop it, unless I reload the mission.

The second bug is that sometimes the game will like cut off my keyboard and I will be unable to use any keys on my keyboard. Reloading the game seems to be the only way to fix this.

The last bug is that I can't seem to switch keys for the heating and cooling controls. It just crashed the game and gives me some weird error message I am unable to understand.

I am using the latest 1.0.8 patch on a Windows 7 64-bit system.


Mon Sep 28, 2015 4:19 am
Profile
OW Support Owner
OW Support Owner
User avatar

Joined: Wed Dec 28, 2005 11:13 pm
Posts: 4994
Location: UK, Scotland
 Re: 3 annoying bugs
ROCKNROLLKID wrote:
The first bug is that sometime the cooling mode will get stuck on and will continuously cool down the ship and there doesn't seem to be a way to stop it, unless I reload the mission.

The second bug is that sometimes the game will like cut off my keyboard and I will be unable to use any keys on my keyboard. Reloading the game seems to be the only way to fix this.


Are the bugs repeatable by doing the same actions or do they happen more oftern in some levels?

ROCKNROLLKID wrote:
The last bug is that I can't seem to switch keys for the heating and cooling controls. It just crashed the game and gives me some weird error message I am unable to understand.

What does the error message say?

_________________
Image
Free Map Editor - Game Requirements - Stucuk.Net
-Stu


Mon Sep 28, 2015 11:46 am
Profile
Soldier level 0
Soldier level 0

Joined: Mon Sep 28, 2015 4:13 am
Posts: 8
 Re: 3 annoying bugs
The cooling bug one happened twice to me, but in different ways. The first time it happened, I was cooling my ship right as a cut scene happened, then after the cut scene, it kept cooling and wouldn't stop. Proceeding on to the next mission, didn't solve the issue. I had to reload a mission before the cooling bug happened to fix it. The second time, I got hit by a missile while I was cooling and it got stuck in again. Both of these times were on different missions, too.

The keyboard issue kind of just happened out of no where. It actually happened after the first time I had the issue with cooling bug. As a proceeded on with the mission with the cooling bug, after sometime, it is like the game just cut off my keyboard and I was unable to use any keys on my keyboard, however, my mouse was stilling working fine. It wasn't a keyboard issue because I could still turn the numlock and caps lock keys on as the lights were turning on, too. Maybe this bug relates with the cooling bug somehow?

As for the error I got trying to change the heating and cooling key, it crashed me game and gave me this error message:

General Info
------------
Application : Dark Horizon
Filename : dark_horizon.exe
Version : 1.0.8.0

Params :
ParamCount : 0

System : empty_system
FPU State : pmSingle, rmNearest, exInvalidOp, exDenormalized, exZeroDivide, exOverflow, exUnderflow, exPrecision

Error Info
----------
ErrorText 0 : Script ERROR: loadData error: îøèáêà çàãðóçêè îáüåêòà playerSettings èç ôàéëà data/profiles/profile_93563649/settings.lua

Exception : None
GetLastError() : The operation completed successfully.


LUA Debug
---------
Debug 3 : Source: loadData("playerSettings","data/profiles/profile_93563649/settings.lua")
: What: main
: NameWhat:
: LineDefined: 0
: CurrentLine: 1
Debug 2 : Source: @D:\delphi\Tarr\Game_DH\Compiled\scripts\funcs\saveload_funcs.lua
: What: Lua
: Name: loadData
: NameWhat: global
: LineDefined: 62
: CurrentLine: 66
Debug 1 : Source: @D:\delphi\Tarr\Game_DH\Compiled\scripts\funcs\error_funcs.lua
: What: Lua
: Name: err
: NameWhat: global
: LineDefined: 176
: CurrentLine: 178
Debug 0 : Source: =[C]
: What: C
: Name: engine_Error
: NameWhat: global
: LineDefined: -1
: CurrentLine: -1

Windows Info
------------
Product : Windows 7 Ultimate v6.1
Win32MajorVersion : 6
Win32MinorVersion : 1
BuildNumber : 7601
ServicePack : Service Pack 1
ServicePackMajor : 1
ServicePackMinor : 0

Hardware Info
-------------
Physical Memory : 4097MB
CPU Name : AMD FX(tm)-6200 Six-Core Processor
CPU Clock : 3791Mhz
VideoCard : AMD Radeon R9 200 Series
Resolution : 1920x1080

The only way to fix this bug is to delete the entire profile I created. I am not sure if this happens if I just try to change 1 or the other or if it happens with both. I do not want to test it, though, because if I did, I will have to delete the entire profile folder again and restart the game and I am already some ways in the game and don't want to have to restart again.


Mon Sep 28, 2015 5:06 pm
Profile
Soldier level 0
Soldier level 0

Joined: Mon Sep 28, 2015 4:13 am
Posts: 8
 Re: 3 annoying bugs
The cooling being stuck on bug just happened again. I was just cooling the ship down, this time there wasn't any enemy ships and no cutscenes happened either. Once again, it happened on a different mission then the last 2 times. However, I noticed something. It doesn't actually say cooling as the bar is going up, when it is stuck on. The bar, where it shows the amount of heat and cooling, will keep going up, but it doesn't say cooling, however, it is still going up and will eventually enter shadow mode when it reaches that far. As I said, pressing the cooling key again doesn't stop it and the only way to fix it is to reload a saved game before it happened. Going onto the next mission doesn't fix it, either.

Anyway you can release a quick patch to fix these issues?


Mon Sep 28, 2015 8:04 pm
Profile
OW Support Owner
OW Support Owner
User avatar

Joined: Wed Dec 28, 2005 11:13 pm
Posts: 4994
Location: UK, Scotland
 Re: 3 annoying bugs
Which key are you trying to bind when you get the error message? the ' key may cause issues.

_________________
Image
Free Map Editor - Game Requirements - Stucuk.Net
-Stu


Tue Sep 29, 2015 5:43 pm
Profile
Soldier level 0
Soldier level 0

Joined: Mon Sep 28, 2015 4:13 am
Posts: 8
 Re: 3 annoying bugs
I am trying to switch to the colon key (:) and the quotes key ("). Perhaps you are right and the game just doesn't recognize the keys.

I am not so much worried about this bug as I am with the other bugs. Anyway to fix the other 2 bugs or anyway you can release a quick patch to fix the other 2 bugs?

If you want, I can try to upload a video of the cooling bug, if you need a better example of what I am talking about.


Tue Sep 29, 2015 6:20 pm
Profile
OW Support Owner
OW Support Owner
User avatar

Joined: Wed Dec 28, 2005 11:13 pm
Posts: 4994
Location: UK, Scotland
 Re: 3 annoying bugs
ROCKNROLLKID wrote:
I am trying to switch to the colon key (:) and the quotes key ("). Perhaps you are right and the game just doesn't recognize the keys.


If your using an American keyboard then the " key is actually the ' key (Only being the " when you hold shift). The settings file uses ' for defining a string. I.E 'A' which would become ''' if you used the ' key. Should be fixable (As LUA also can use "" for defining a string).

ROCKNROLLKID wrote:
I am not so much worried about this bug as I am with the other bugs. Anyway to fix the other 2 bugs or anyway you can release a quick patch to fix the other 2 bugs?

If you want, I can try to upload a video of the cooling bug, if you need a better example of what I am talking about.

How quick all depends on how easy i can reproduce it and then work out whats going wrong.

_________________
Image
Free Map Editor - Game Requirements - Stucuk.Net
-Stu


Tue Sep 29, 2015 9:34 pm
Profile
Soldier level 0
Soldier level 0

Joined: Mon Sep 28, 2015 4:13 am
Posts: 8
 Re: 3 annoying bugs
Ah ok. Will you release it in 1.0.9?

Also, when I patch the game, do I need to do all the patches from order or is it ok if I just did 1.0.8 patch? I previously just had 1.0.0 before I patched to 1.0.8.


Wed Sep 30, 2015 12:00 am
Profile
OW Support Owner
OW Support Owner
User avatar

Joined: Wed Dec 28, 2005 11:13 pm
Posts: 4994
Location: UK, Scotland
 Re: 3 annoying bugs
ROCKNROLLKID wrote:
Also, when I patch the game, do I need to do all the patches from order or is it ok if I just did 1.0.8 patch? I previously just had 1.0.0 before I patched to 1.0.8.


The patch contains everything.

_________________
Image
Free Map Editor - Game Requirements - Stucuk.Net
-Stu


Wed Sep 30, 2015 12:40 am
Profile
OW Support Owner
OW Support Owner
User avatar

Joined: Wed Dec 28, 2005 11:13 pm
Posts: 4994
Location: UK, Scotland
 Re: 3 annoying bugs
So far i have been unable to recreate the cooling bug. Is there any repeatable way of reproducing it or is it just random?

_________________
Image
Free Map Editor - Game Requirements - Stucuk.Net
-Stu


Thu Oct 01, 2015 7:00 pm
Profile
Soldier level 0
Soldier level 0

Joined: Mon Sep 28, 2015 4:13 am
Posts: 8
 Re: 3 annoying bugs
As far as I am concerned, it happens randomly. Normally I am just cooling the ship down and sometimes it will just happen. Maybe it is an issue with USA keyboards? I know this game was never really released in USA, so perhaps that is the issue?


Fri Oct 02, 2015 10:58 pm
Profile
OW Support Owner
OW Support Owner
User avatar

Joined: Wed Dec 28, 2005 11:13 pm
Posts: 4994
Location: UK, Scotland
 Re: 3 annoying bugs
ROCKNROLLKID wrote:
As far as I am concerned, it happens randomly. Normally I am just cooling the ship down and sometimes it will just happen. Maybe it is an issue with USA keyboards? I know this game was never really released in USA, so perhaps that is the issue?


What keyboard/language you use shouldn't be an issue. Did you try version 1.0 or just patch straight to 1.0.8? May be a bug that was introduced in a later patch.

_________________
Image
Free Map Editor - Game Requirements - Stucuk.Net
-Stu


Sun Oct 04, 2015 8:46 am
Profile
Soldier level 0
Soldier level 0

Joined: Mon Sep 28, 2015 4:13 am
Posts: 8
 Re: 3 annoying bugs
This was happening in 1.0 as well. Then I patched to 1.0.8 and it was still happening, which is why I asked if I needed to go through all the other patches before I did 1.0.8.


Mon Oct 05, 2015 5:51 pm
Profile
OW Support Owner
OW Support Owner
User avatar

Joined: Wed Dec 28, 2005 11:13 pm
Posts: 4994
Location: UK, Scotland
 Re: 3 annoying bugs
I will try and find time to do several missions and see if i get the bug(Though i may not have access to this computer tomorrow). The problem is that if i can't recreate the bug then its a needle in a haystack situation. If i can get it then i can take a look at whats going on inside the game at the time its happening.

_________________
Image
Free Map Editor - Game Requirements - Stucuk.Net
-Stu


Tue Oct 06, 2015 12:54 am
Profile
Soldier level 0
Soldier level 0

Joined: Mon Sep 28, 2015 4:13 am
Posts: 8
 Re: 3 annoying bugs
Alright, let me know your results when you are finish. Goodluck!


Tue Oct 06, 2015 11:03 pm
Profile
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 15 posts ] 


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Original Skin by Vjacheslav Trushkin.
Tarr Support version by Stucuk.